Create a Bootable Ubuntu Usb Stick on MacOS

Createing a bootable ubuntu usb by using command prompt on MacOS

ta-ching chen

1 minute read

 Table of Contents

First Things First 

Convert ISO to Dmg Format 

$ hdiutil convert -format UDRW -o /path/to/<target-image> /path/to/<source-image>

Choose the Target Usb 

$ diskutil list

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage Macintosh HD            250.1 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           +249.8 GB   disk1
                                 Logical Volume on disk0s2
                                 76F1BFBE-3D0C-4C5C-9C4A-02FD5A1CA5D9
                                 Unencrypted
/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS MacintoshHD             499.8 GB   disk2s2
  • find out your target usb stick
# /dev/disk2 is only for tutorial! Please choose your own.
$ diskutil unmountDisk /dev/disk2

Start to Create the Bootable Usb 

  • always backup important data in usb before you start
  • use rdisk instead of disk here. ex. rdisk2
$ sudo dd if=/path/to/<target-image-just-convert>.dmg of=/dev/rdisk2 bs=1m
$ diskutil eject /dev/disk2
To reproduce, republish or re-use the content, please attach with link: https://tachingchen.com/
comments powered by Disqus