Mac

Create a Bootable Ubuntu Usb Stick on MacOS

Createing a bootable ubuntu usb by using command prompt on MacOS

ta-ching chen

1 minute read

First Things First

Convert ISO to Dmg Format

$ hdiutil convert -format UDRW -o /path/to/<target-image> /path/to/<source-image>

Choose the Target Usb

$ diskutil list

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage Macintosh HD            250.1 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           +249.8 GB   disk1
                                 Logical Volume on disk0s2
                                 76F1BFBE-3D0C-4C5C-9C4A-02FD5A1CA5D9
                                 Unencrypted
/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS MacintoshHD             499.8 GB   disk2s2

Change MacOS Screenshot Save Location

Guide to change MacOS screenshot save location

ta-ching chen

1 minute read

Change Default Path

Type following commands in terminal

defaults write com.apple.screencapture location /path/to/target/directory/
killall SystemUIServer

Remove Shadow

If you also want to remove the shadow of window screenshots

defaults write com.apple.screencapture disable-shadow -bool true
killall SystemUIServer